02/09/2025 - iSAMS Peformance

Incident Report for iSAMS Ltd

Resolved

Good afternoon,
Please accept our apologies for any inconvenience caused - the server has now been expanded and services restarted. Full service has now resumed.
Posted Sep 02, 2025 - 16:34 BST

Investigating

Dear Customers,
We are aware of reports of slowness on one server, this is currently being investigated by our resolution teams.
We will provide further updates shortly.
Posted Sep 02, 2025 - 15:22 BST
This incident affected: Hosting Infrastructure (London (UK) Data Centre).