30/04/2026 - iSAMS Performance

Incident Report for iSAMS Ltd

Resolved

Dear customers,
This issue has been resolved, if you are still experiencing any problems please contact our support team.
Posted Apr 30, 2026 - 11:10 BST

Investigating

Dear Customers,
We are aware of an issue affecting a small number of our customers, Our resolution team are currently working on a solution.
Please accept our apologies for any disruption to services.
Posted Apr 30, 2026 - 08:09 BST
This incident affected: Hosting Infrastructure (London (UK) Data Centre).