Dear customers, This issue is resolved - there appears to be a minor short external outage and no remedial action was required by iSAMS to bring services back online.
Posted May 21, 2026 - 12:35 BST
Investigating
Dear Customers, We are aware of an issue affecting some of our customers. This is being investigated as a priority and we will provide further updates shortly. Kind regards
Posted May 21, 2026 - 11:50 BST
This incident affected: Hosting Infrastructure (London (UK) Data Centre, Southeast Asia Data Centre).