18/11/2025 - iSAMS Portals - CloudFlare Global Outage

Incident Report for iSAMS Ltd

Resolved

CLoudflare have now released a solution and as a result services are now back online.
Posted Nov 18, 2025 - 15:00 GMT

Investigating

Dear Customers,
We are aware of an issue at Cloudflare that is impacting on services for some of our portals. our teams are aware and are monitoring for updates from Cloudflare.
Updates can be found here - https://www.cloudflarestatus.com/
We apologise for any disruption caused during this period.
Posted Nov 18, 2025 - 13:24 GMT
This incident affected: Hosting Infrastructure (London (UK) Data Centre, Southeast Asia Data Centre).