17/09/2025 - iSAMS iParent, iStudent, or iTeacher apps

Incident Report for iSAMS Ltd

Resolved

This issue has now been resolved - should any customer still be experiencing any issues please raise a ticket with the support team.
Posted Oct 09, 2025 - 13:04 BST

Update

Dear Customers,
Our resolution team are continuing to work on a resolution for this issue. Thank you for your patience during this period.
Posted Sep 19, 2025 - 10:20 BST

Update

We are continuing to investigate this issue.
Posted Sep 17, 2025 - 17:08 BST

Investigating

Dear Customers,
If you use the iParent, iStudent, or iTeacher apps and have updated your devices to iOS 26, you may have noticed some UI or functionality issues following the update. We’re aware of the problem and our team is actively working on a fix. Thank you for your patience while we resolve this as quickly as possible.
Posted Sep 17, 2025 - 17:07 BST
This incident affected: Internal Applications & Services (Company Website (Public), Documentation Portal (Public)).