Dear Customers, This issue is now resolved. Kind regards
Posted May 26, 2026 - 10:14 BST
Investigating
Dear customers, We are aware of an issue affecting some users with the https://www.isams.com/ page. Our teams are investigating. Please accept our apologies for any inconvenience.
Posted May 25, 2026 - 21:46 BST
This incident affected: Internal Applications & Services (Company Website (Public)).