A Post Incident Review will be completed and affected users will be contacted. We apologise for any inconvenience caused.
Posted Aug 21, 2026 - 07:10 BST
Investigating
Dear Customers,
We are aware of an iSAMS Down error that is impacting service availability for some users. Our team are actively working on a solution to bring these services back online as a matter of urgency.
We are sorry for the issues you may be experiencing, we will share updates via our Service Status page.
Posted Aug 20, 2026 - 23:16 BST
This incident affected: Hosting Infrastructure (Southeast Asia Data Centre).