20/04/2026 iSAMS Performance Issues

Incident Report for iSAMS Ltd

Resolved

Dear customers,
Services have been restored and our team are continuing to investigate the root cause of the issue. As soon as further information is available we will update tickets.
Please accept our apologies for any disruption.
Posted Apr 20, 2026 - 11:36 BST

Investigating

Dear Customers,
We are aware of some customers experiencing performance issues. Our teams are actively investigating this as a matter of urgency and updates will be provided as soon as possible.
Please accept our apologies for any disruption.
Posted Apr 20, 2026 - 08:25 BST
This incident affected: Hosting Infrastructure (London (UK) Data Centre).